Conda install broken?

Hello, I have just been met with the following error across all of my anaconda distributions across various platforms when upgrading conda and despite several clean installs all attempts to install matminer via “conda install -c conda-forge matminer” result in the following message

(main36) C:\Users\mm049>conda install -c conda-forge matminer
Collecting package metadata (current_repodata.json): done
Solving environment: failed with initial frozen solve. Retrying with flexible solve.
Solving environment: failed with repodata from current_repodata.json, will retry with next repodata source.
Collecting package metadata (repodata.json): done
Solving environment: failed with initial frozen solve. Retrying with flexible solve.
Solving environment: -
Found conflicts! Looking for incompatible packages.
This can take several minutes. Press CTRL-C to abort.
failed

UnsatisfiableError: The following specifications were found to be incompatible with each other:

Package future conflicts for:
matminer -> future[version=’>=0.16.0’]
Package scikit-learn conflicts for:
matminer -> scikit-learn[version=’>=0.21.3’]
Package ujson conflicts for:
matminer -> ujson[version=’>=1.35’]
Package six conflicts for:
matminer -> six[version=’>=1.11.0’]
Package sqlite conflicts for:
python=3.6 -> sqlite[version=’>=3.25.3,<4.0a0|>=3.26.0,<4.0a0|>=3.29.0,<4.0a0’]
Package vc conflicts for:
python=3.6 -> vc[version=‘14.*|>=14,<15.0a0|>=14.1,<15.0a0’]
Package pymongo conflicts for:
matminer -> pymongo[version=’>=3.6.1’]
Package aflow conflicts for:
matminer -> aflow[version=’>=0.0.9’]
Package pint conflicts for:
matminer -> pint[version=’>=0.8.1’]
Package monty conflicts for:
matminer -> monty[version=’>=3.0.1’]
Package citrination-client conflicts for:
matminer -> citrination-client[version=’>=4.0.1’]
Package dscribe conflicts for:
matminer -> dscribe[version=’>=0.2.9’]
Package httplib2 conflicts for:
matminer -> httplib2[version=’>=0.10.3’]
Package ase conflicts for:
matminer -> ase[version=’>=3.14.1’]
Package sympy conflicts for:
matminer -> sympy[version=’>=1.1.1’]
Package numpy conflicts for:
matminer -> numpy[version=’>=1.17.2’]
Package jmespath conflicts for:
matminer -> jmespath[version=’>=0.9.3’]
Package pip conflicts for:
python=3.6 -> pip
Package pymatgen conflicts for:
matminer -> pymatgen[version=’>=2019.10.2’]
Package tqdm conflicts for:
matminer -> tqdm[version=’>=4.23.1’]
Package vs2015_runtime conflicts for:
python=3.6 -> vs2015_runtime
Package mdf_forge conflicts for:
matminer -> mdf_forge[version=’>=0.6.1’]
Package requests conflicts for:
matminer -> requests[version=’>=2.20.0’]
Package pandas conflicts for:
matminer -> pandas[version=’>=0.23.4’]
Package plotly conflicts for:
matminer -> plotly[version=’>=3.2.1’]

Is there a problem with the repository or is there a problem on my end?

Kind Regards

Michael Moran

I haven’t seen this error before, but suspect that it could be an issue with your conda environments.

Could you try creating a fresh Python 3.7 environment (e.g., conda create --name matminer python==3.7.*) and then install matminer in that new environment?

That will help us figure out if the problem is particular to your environment.

Hey Michael, did you resolve your issue or is the conda install still broken for you?

Thanks,
Alex

Hi Ardunn, in the end I had to completly remove conda and then do a few force updates through apt before reinstalling it.

It’s fine now, probably an issue with my OS.

1 Like

Hi I’ve had the issue again on another environment and have tried to resinstall anaconda from scratch and tried python 3.6 and 3.7 virtual envs to no avail, error is identical.

Hey MIchael,

Thanks for the update. This issue has been added to the github repo and we will work on fixing it. We’ll udpate this thread when things are fixed!

Thanks,
Alex